December 18, 2005

The Magic of Free Software Community

Posted in Computers, Linux at 3:39 pm by pmatos

I think most of us, from the daily use and contribution to the Free Software Community have already felt the magic, however, not wanting to dimish other helps, yesterday a race to make stuff work on my VoIP system made me happy so I just need to talk about it. First of all, the basics. Yesterday I was using Gentoo Linux kernel version 2.6.14-gentoo-r2. I kept trying to get a VoIP software to work. Skype is nice but uses deprecated OSS, Gizmo, although it seems a recent project also uses OSS and I wanted to use the latest tech/software, not deprecated protocols, libraries or whatever so I tried GnomeMeeting (GM) since it uses ALSA and integrates smoothly with my GNOME system. But first I needed some headsets. My girlfriend just bought one headsets for 20€ but I recalled I have some USB headsets that came with the fantastic SOCOM2 game for my PS2. So I gave it a try. Linux obviously recognized the headset and it was easy to set it up with ALSA using usb-sound driver. But for some reason it was not working on GM. I waited a few days until I had some time to check it out. Finally yesterday I got to try it. Problem was I could only try it on the GM druid or with my girlfriend which meant I had to test it when my girlfriend had the time for it which is almost ‘never’. But my sound worked with the GM druid I could talk and listen to my self. So I tried to go to the #gnomemeeting @ FreeNode which TheBonsai informed me of a very cool echo server at h323:h323.voxgratia.org so I tried and it happened the same it happened once with my girlfriend. The other side could hear me but I could not hear the other side so I sent a message to the Gnome Meeting Mailing List. Minutes later I had a reply, which I replied to and to which I received another reply.

Fact is, after a bunch of hours and something like 40 messages between myself and Damien, GM creator, I found a solution to the problem. It was about my kernel. A bug I had read about in the Gentoo Forums sometime ago but I forgot it could be about that because it was strange it worked with the GM druid. Downgraded to kernel version 2.6.13-gentoo-r5, and it’s working. Anyways, what would happen if I had the luck of using Net Meeting or some other software outside the this great community? I’m sure I would not have the problem solved. Oh well, fortunately everything ended up nicely.

Hurray for Damien, hurray for Gnome Meeting, hurray for Linux Community, hurray for Free Software Community…

And if YOU are not part of it… you’re welcome to join! :)

1 Comment »

  1. Mário Lopes said,

    That’s it! Free Software is just great. :-)


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: